Xen 4.8.0.bb: Difference between revisions
From Xen
Jump to navigationJump to search
(Created page with " require recipes-extended/xen/xen.inc DEPENDS += " iasl-native" RDEPENDS_${PN}-xenstore = "bash" FILES_${PN}-xenstore += "\ /usr/lib/xen/bin/init-xenstore-domai...") |
No edit summary |
||
Line 8: | Line 8: | ||
/usr/lib/xen/bin/init-xenstore-domain \ |
/usr/lib/xen/bin/init-xenstore-domain \ |
||
/etc/xen/scripts/launch-xenstore \ |
/etc/xen/scripts/launch-xenstore \ |
||
" |
|||
FILES_${PN}-libxenstat += "\ |
|||
/usr/share/pkgconfig/xenstat.pc \ |
|||
" |
|||
FILES_${PN}-libblktapctl += "\ |
|||
/usr/share/pkgconfig/xenblktapctl.pc \ |
|||
" |
|||
FILES_${PN}-libxenstore += "\ |
|||
/usr/share/pkgconfig/xenstore.pc \ |
|||
" |
|||
FILES_${PN}-libxentoollog += "\ |
|||
/usr/share/pkgconfig/xentoollog.pc \ |
|||
" |
|||
FILES_${PN}-libxenctrl += "\ |
|||
/usr/share/pkgconfig/xencontrol.pc \ |
|||
" |
|||
FILES_${PN}-libxenguest += "\ |
|||
/usr/share/pkgconfig/xenguest.pc \ |
|||
" |
|||
RDEPENDS_${PN}-base += "\ |
|||
${PN}-libxendevicemodel \ |
|||
" |
|||
PACKAGES += "\ |
|||
${PN}-libxendevicemodel \ |
|||
" |
|||
FILES_${PN}-libxendevicemodel += "\ |
|||
/usr/share/pkgconfig/xendevicemodel.pc \ |
|||
" |
|||
FILES_${PN}-libxengnttab += "\ |
|||
/usr/share/pkgconfig/xengnttab.pc \ |
|||
" |
|||
FILES_${PN}-libxenvchan += "\ |
|||
/usr/share/pkgconfig/xenvchan.pc \ |
|||
" |
|||
FILES_${PN}-libxencall += "\ |
|||
/usr/share/pkgconfig/xencall.pc \ |
|||
" |
|||
FILES_${PN}-libxenforeignmemory += "\ |
|||
/usr/share/pkgconfig/xenforeignmemory.pc \ |
|||
" |
|||
FILES_${PN}-libxenevtchn += "\ |
|||
/usr/share/pkgconfig/xenevtchn.pc \ |
|||
" |
" |
||
FILES_${PN}-xendomains += "\ |
FILES_${PN}-xendomains += "\ |
||
${sysconfdir}/init.d/xendriverdomain \ |
${sysconfdir}/init.d/xendriverdomain \ |
||
Line 22: | Line 63: | ||
# update to the last commit and branch name |
# update to the last commit and branch name |
||
#SRCREV = "52e137952253b3bcec6f007c99f959cb6dbb96b4" |
|||
#SRC_URI = "git:///local/repos/xen-upstream;protocol=file;branch=ppp32;" |
|||
SRCREV = "de22e0dd0df7244052b978fdd939aae7a0937077" |
SRCREV = "de22e0dd0df7244052b978fdd939aae7a0937077" |
||
SRC_URI = "git://xenbits.xen.org/xen.git;protocol=git;branch=staging;" |
SRC_URI = "git://xenbits.xen.org/xen.git;protocol=git;branch=staging;" |
Revision as of 20:04, 20 April 2017
require recipes-extended/xen/xen.inc DEPENDS += " iasl-native" RDEPENDS_${PN}-xenstore = "bash" FILES_${PN}-xenstore += "\ /usr/lib/xen/bin/init-xenstore-domain \ /etc/xen/scripts/launch-xenstore \ " FILES_${PN}-libxenstat += "\ /usr/share/pkgconfig/xenstat.pc \ " FILES_${PN}-libblktapctl += "\ /usr/share/pkgconfig/xenblktapctl.pc \ " FILES_${PN}-libxenstore += "\ /usr/share/pkgconfig/xenstore.pc \ " FILES_${PN}-libxentoollog += "\ /usr/share/pkgconfig/xentoollog.pc \ " FILES_${PN}-libxenctrl += "\ /usr/share/pkgconfig/xencontrol.pc \ " FILES_${PN}-libxenguest += "\ /usr/share/pkgconfig/xenguest.pc \ " RDEPENDS_${PN}-base += "\ ${PN}-libxendevicemodel \ " PACKAGES += "\ ${PN}-libxendevicemodel \ " FILES_${PN}-libxendevicemodel += "\ /usr/share/pkgconfig/xendevicemodel.pc \ " FILES_${PN}-libxengnttab += "\ /usr/share/pkgconfig/xengnttab.pc \ " FILES_${PN}-libxenvchan += "\ /usr/share/pkgconfig/xenvchan.pc \ " FILES_${PN}-libxencall += "\ /usr/share/pkgconfig/xencall.pc \ " FILES_${PN}-libxenforeignmemory += "\ /usr/share/pkgconfig/xenforeignmemory.pc \ " FILES_${PN}-libxenevtchn += "\ /usr/share/pkgconfig/xenevtchn.pc \ " FILES_${PN}-xendomains += "\ ${sysconfdir}/init.d/xendriverdomain \ " # these 3 are for xen 4.9: PACKAGES += "${PN}-xendevicemodel ${PN}-xendevicemodel-dev" FILES_${PN}-xendevicemodel += "${libdir}/libxendevicemodel.so.*" FILES_${PN}-xendevicemodel-dev += "${libdir}/libxendevicemodel.so" DEFAULT_PREFERENCE = "1" # update to the last commit and branch name #SRCREV = "52e137952253b3bcec6f007c99f959cb6dbb96b4" #SRC_URI = "git:///local/repos/xen-upstream;protocol=file;branch=ppp32;" SRCREV = "de22e0dd0df7244052b978fdd939aae7a0937077" SRC_URI = "git://xenbits.xen.org/xen.git;protocol=git;branch=staging;" S = "${WORKDIR}/git" LIC_FILES_CHKSUM = "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095" # Xen suffixes the libexecdir within its configure scripts, prevent the nested xen/xen/ libexecdir = "${libdir}" # These options override detected values from the build. EXTRA_OECONF_append += " \ --with-initddir=${INIT_D_DIR} \ --with-sysconfig-leaf-dir=default \ --with-system-qemu=/usr/bin/qemu-system-i386 \ --disable-qemu-traditional \ " EXTRA_OEMAKE += "CROSS_COMPILE=${TARGET_PREFIX} APPEND_CFLAGS=-Wno-error"