Xen 4.8.0.bb

From Xen
Revision as of 19:06, 20 April 2017 by StefanoStabellini (talk | contribs) (Created page with " require recipes-extended/xen/xen.inc DEPENDS += " iasl-native" RDEPENDS_${PN}-xenstore = "bash" FILES_${PN}-xenstore += "\ /usr/lib/xen/bin/init-xenstore-domai...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
require recipes-extended/xen/xen.inc

DEPENDS += " iasl-native"

RDEPENDS_${PN}-xenstore = "bash"

FILES_${PN}-xenstore += "\
     /usr/lib/xen/bin/init-xenstore-domain \
     /etc/xen/scripts/launch-xenstore \
    "

FILES_${PN}-xendomains += "\
    ${sysconfdir}/init.d/xendriverdomain \
    "

# these 3 are for xen 4.9:
PACKAGES += "${PN}-xendevicemodel ${PN}-xendevicemodel-dev"
FILES_${PN}-xendevicemodel += "${libdir}/libxendevicemodel.so.*"
FILES_${PN}-xendevicemodel-dev += "${libdir}/libxendevicemodel.so"

DEFAULT_PREFERENCE = "1"

# update to the last commit and branch name
SRCREV = "de22e0dd0df7244052b978fdd939aae7a0937077"
SRC_URI = "git://xenbits.xen.org/xen.git;protocol=git;branch=staging;"

S = "${WORKDIR}/git"

LIC_FILES_CHKSUM = "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095"

# Xen suffixes the libexecdir within its configure scripts, prevent the nested xen/xen/
libexecdir = "${libdir}"

# These options override detected values from the build.
EXTRA_OECONF_append += " \
    --with-initddir=${INIT_D_DIR} \
    --with-sysconfig-leaf-dir=default \
    --with-system-qemu=/usr/bin/qemu-system-i386 \
    --disable-qemu-traditional \
    "
EXTRA_OEMAKE += "CROSS_COMPILE=${TARGET_PREFIX} APPEND_CFLAGS=-Wno-error"