Xen 4.8.0.bb

From Xen
Jump to navigationJump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.
require recipes-extended/xen/xen.inc

DEPENDS += " iasl-native"

RDEPENDS_${PN}-xenstore = "bash"

FILES_${PN}-xenstore += "\
     /usr/lib/xen/bin/init-xenstore-domain \
     /etc/xen/scripts/launch-xenstore \
     "

# The followings are for Xen 4.9:
FILES_${PN}-libxenstat += "\
     ${datadir}/pkgconfig/xenstat.pc \
    "
FILES_${PN}-libblktapctl += "\
     ${datadir}/pkgconfig/xenblktapctl.pc \
    "
FILES_${PN}-libxenstore += "\
     ${datadir}/pkgconfig/xenstore.pc \
    "
FILES_${PN}-libxentoollog += "\
     ${datadir}/pkgconfig/xentoollog.pc \
    "
FILES_${PN}-libxenctrl += "\
     ${datadir}/pkgconfig/xencontrol.pc \
    "
FILES_${PN}-libxenguest += "\
     ${datadir}/pkgconfig/xenguest.pc \
    "
FILES_${PN}-libxengnttab += "\
     ${datadir}/pkgconfig/xengnttab.pc \
    "
FILES_${PN}-libxenvchan += "\
     ${datadir}/pkgconfig/xenvchan.pc \
    "
FILES_${PN}-libxencall += "\
     ${datadir}/pkgconfig/xencall.pc \
    "
FILES_${PN}-libxenforeignmemory += "\
     ${datadir}/pkgconfig/xenforeignmemory.pc \
    "
FILES_${PN}-libxenevtchn += "\
     ${datadir}/pkgconfig/xenevtchn.pc \
    "
FILES_${PN}-xendomains += "\
    ${sysconfdir}/init.d/xendriverdomain \
    "
PACKAGES += "${PN}-xendevicemodel ${PN}-xendevicemodel-dev"
FILES_${PN}-xendevicemodel += "\
    ${libdir}/libxendevicemodel.so.* \
    ${datadir}/pkgconfig/xendevicemodel.pc \
    "
FILES_${PN}-xendevicemodel-dev += "${libdir}/libxendevicemodel.so"

DEFAULT_PREFERENCE = "1"

# update to the last commit and branch name
SRCREV = "de22e0dd0df7244052b978fdd939aae7a0937077"
SRC_URI = "git://xenbits.xen.org/xen.git;protocol=git;branch=staging;"

S = "${WORKDIR}/git"

LIC_FILES_CHKSUM = "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095"

# Xen suffixes the libexecdir within its configure scripts, prevent the nested xen/xen/
libexecdir = "${libdir}"

# These options override detected values from the build.
EXTRA_OECONF_append += " \
    --with-initddir=${INIT_D_DIR} \
    --with-sysconfig-leaf-dir=default \
    --with-system-qemu=/usr/bin/qemu-system-i386 \
    --disable-qemu-traditional \
    "
EXTRA_OEMAKE += "CROSS_COMPILE=${TARGET_PREFIX} APPEND_CFLAGS=-Wno-error"